태그 : pip 요약보기전체보기목록닫기

1 2

[Python] 프로그램 내에서 모듈 버전 정보 구해오기

일반적으로 설치된 모듈의 버전 정보를 구해 오려면,리눅스 에서는$ pip freeze | grep lxmllxml==2.3윈도우 에서는c:\> pip freeze | findstr lxmllxml==2.3와 같은 방식으로 버전 체크를 하고는 합니다.그런데 필요에 따라 파이썬 스크립트 안에서 버전을 가져올 필요가 있습니다.그런 경우에는 아래와 같이 ...

[Python] pip install 시 UNKNOWN 으로 설치되는 경우

파이썬으로 작업을 deploy 하다보니 별의 별 경우가 다...최근 필요에 따라 gTTS 모듈을 pip로 설치하는데,다음과 같이,C:\>pip install gTTSCollecting gTTS  Using cached https://files.pythonhosted.org/packages/e6/37/f55346a736278f0eb0ae9f...

[Python] pyenv, conda, virtualenv, pip, autoenv

맥이나 리눅스는 기본적으로 파이썬 인터프리터가 들어 있습니다.따라서 터미널에서 $ python -V해보면 버전을 보여줄 것입니다. (버전1에서는 -V 옵션이 없었네요 ^^)그런데 말입니다.파이썬을 개발하다 보면 많은 3-rd party 모듈을 설치하고는 합니다.처음에는 소스 째 가져다가 $ easy_install 등의 명령을 ...

[Python] Conda에 대한 간단 고찰 및 mac에서 Jupyter notebook 시 오류 해결

몇년전 블로그 내용에서 easy_install 대신 pip를 사용하는 것이 낫다고 하였는데,최근에는 거의 pip로 모두 기술되고 있는 상황입니다.그리고 이제는 대부분의 개발 테스트 등을 모두 VirtualEnv 환경에서 개발하고 있습니다.(VirtualEnv 에 관한 내용)간단히 여러 버전의 Python이 설치되어 있다고 할 때,$ sudo pip in...

[Python] pip list 시 --format=(legacy|columns) 과 같은 경고가 나오면

바로 이전 블로그에서 pip로 설치할 수 있는 패키지 만드는 법을 올렸었는데요,아마 맥이나 리눅스에서 최신 pip 로 list 명령을 내리다보면,$ pip listDEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns)...

[pypi] 나의 첫번째 pip 패키지 treesel 등록

파이썬 패키지 관리자 중에 pip 가 대세라고 이전에 이야기 한 적이 있습니다.따라서 최근에 파이썬 패키지 설치 시에는 모두 pip 로 통일하여 설치하고 있습니다.그런데 필요에 따라 어떤 유틸리티를 만들어 그것을 이 pypi.python.org 에 등록하여자신 뿐만 아니라 다른 사람들을 위해서 오픈할 수 있습니다.(지금껏 죄송하게도 못했지만 앞...

[Ubuntu 14.04] mariaDB 10 및 pypy 설치와 pypy용 pip

이런 우분투 패키지에 특정 버전의 패키지 설치와 python 이 아닌 pypy 용 pip를 돌리는 것 등은정리해 놓지 않으면 항상 구글링을 하게되어중복일 수도 있지만 또 정리해 봅니다.1) MariaDB 버전 10을 우분투 12.04 혹은 14.04에 설치하기​$ cat install_mariadb_10.sh #!/bin/bash# i...

[Ubuntu12.04] pip 명령에서 InsecurePlatformWarning

우분투에서 최신버전의 pip로 업그레이드 하는 것을 정리한 적이 있는데요.최근에 pip 명령을 내리다가 다음과 같은 경고 메시지가 나타나는 것을 발견하였습니다.찾아보았더니 다음과 같이 하면 해결되더군요.$ sudo apt-get install -y libffi-dev libssl-dev$ sudo pip install requests[security]어...

[CentOS 5.11] Python 2.7.8 및 pip 설치하기

CentOS 5.11 은 아직까지 CentOS 에서 지원을 중단하지 않고 지원되고 있는 것 같습니다.문제는 이 버전에서 파이썬을 2.x를 이용하려는데,버전이 너무 낮습니다.현재 파이썬 2.x의 가장 최신 버전은 2.7.9 (이 글을 쓰고 있는 2015년2월 시점) 이지만,CentOS 5.11 (i386)의 시스템 설치된 파이썬 2.x 버전은 2.4.3 ...

[Python] 파이썬 실행환경의 독립 virtualenv & PyCharm

그동안 python 개발을 하면서 deployment 에는 그렇게 많이 신경을 쓰지 않았었습니다.하지만 결국은 virtualenv 의 필요성을 아주 절감하고는 이렇게 정리를 해 봅니다.예를 들어 개발 소스 (패키지)는A|+-- B|+-- C아래와 같은 식으로 되어 있다고 가정하고,A.B 패키지를 돌리는 파이썬 패키지 등의 개발 환경과 A.C의 ...
1 2

구글애드텍스트